PHP in Eclipse Error: The session could not be started.

If you are trying to run PHP in Eclipse, you may encounter the following error

The session could not be started. In order to generate debug information, please make sure that the debugger is properly configured as a php.ini directive.

This is because you need to install a debugger in your system. There are two options available.

  1. Xdebug
  2. Zend Debugger

So, if you are in Ubuntu Linux, you can resolve the issue

$ sudo apt-get install php5-xdebug


$ sudo apt-get install zend-framework


Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s